This is required flash 9.0 or higher